gnuplot caca terminal work on Cygwin-x86 but not Cygwin-x86_64

Corinna Vinschen corinna-cygwin@cygwin.com
Mon May 5 10:42:00 GMT 2014


On May  1 19:07, Tatsuro MATSUOKA wrote:
> Hello 
> 
> I have tried to build the recent cvs snapshot of gnuplot both on Cygwin-x86 and Cygwin-x86_64.
> 
> The caca terminal works correctly on the Cygwin-x86. However it does not work on  Cygwin-x86_64.
> 
> First I have reported in the bug-ticket on the SourceForge of gnuplot. 
> https://sourceforge.net/p/gnuplot/bugs/1391/
> 
> But I feel that this is not the gnuplot issue but Cygwin-x86_64 issue. Because the caca terminal works fine on  Cygwin-x86
> 
> I have tried to execute gnuplot(cvs) on gdb.
> 
> gnuplot> set term caca
> Terminal type set to 'caca'
> Options are 'enhanced size 80, 25 background rgb "white" color noinverted charset blocks'
> gnuplot> plot sin(x)
> 
> Program received signal SIGSEGV, Segmentation fault.
> 0x0000000077868e5d in ntdll!RtlUnwindEx ()
>    from /cygdrive/c/Windows/system32/ntdll.dll
> (gdb) 
> 
> The Segmentation fault is occured.
> What can I do the further purchase of this issue?

I have a hunch:

Please try the latest snapshot DLL from http://cygwin.com/snhapshots/

The above crash looks like it might be a wrongly catched exception in
one of the Windows DLLs.  If so, this would be a result of a glitch in
the 64 bit exception handling, which should be fixed in the latest
snapshots.


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20140505/a7e04705/attachment.sig>


More information about the Cygwin mailing list