directory troubles

Richard richard@KarmannGhia.org
Tue Mar 25 19:54:00 GMT 2014


Hi Folks,

...I have for more than ten years used links in specific directories as a 
strategy of managing disk space, distinguishing between remote (NFS / 
Samba) from local, and I've applied the same strategy to help in keeping 
my linux and Cygwin installations as similar as possible. Now, something 
has gone wrong on one system and I'm perplexed - I'm pretty darned sure it 
was working "last time I checked!"

Consider /d for local disk mounts, /nfs for remote disk mounts and /l for 
"local use" which links into trees wherever. In this case, /d and /l were 
broken, but the nfs directory and its mounts seem to be unaffected.

This morning I went to /opt which ordinarily translates to /l/opt (which 
itself translates to /d/c/opt or /d/b/opt), but Cygwin's Bash shell 
wouldn't go there. I got:

-bash: cd: /opt: No such file or directory

Investigating, ls showed the directories /d and /l, but I couldn't cd into 
them. ls -l showed simply:

ls: cannot access d: No such file or directory
ls: cannot access l: No such file or directory
d??????????  ? ?       ?                   ?            ? d
d??????????  ? ?       ?                   ?            ? l

Since these directories only contain links, I decided to remove them and 
make them anew. Oops! That didn't work! When Cygwin decided it wasn't 
going to delete them, I first tried a cmd window, but it complained the 
directories weren't empty. When I "got inside" them, I found only . and .. 
as subdirectories - again, as reported by cmd. There was no removing 
those, either. So, I used an Explorer window. It permitted me to see the 
link names - all looked good - and it worked at deleting them - at least, 
they no longer show up from either Windows or Cygwin tools.

But when I try and recreate them, I get:

mkdir: cannot create directory `d': No such file or directory
mkdir: cannot create directory `l': No such file or directory

-frown- Not sure what to do next, I tried creating them from the same 
Windows explorer window I used to delete them, but it says, "Unable to 
create the folder 'New Folder' Access is denied."

This is on "corporate edition XP 64 bit" - I am the administrator but 
there is a different "Administrator" account for which I don't know the 
password (never remember even setting the administrator password from the 
first installation)! On this version there isn't a "run as administrator", 
only a "run as", and since I don't know the password, I can't use the 
administrator account directly unless I figure out how to deal with the 
password. I also have tried (of course) unchecking the box about limiting 
privileges, but that didn't help either.

Normally I'd just ignore this and work around it somehow, but these 
directories are pretty critical to the whole file system management 
strategy, so it'd be nice to not have to reinstall everything - 
reinstalling cygwin is among the most painful processes I can imagine as 
it virtually never works right the first time out and is possibly a 
multi-day process. Beyond that, any and all insights on where I went 
wrong, etc, etc, are very much appreciated.

BTW, in case it matters, this is cygwin 1.7.25.

Thanks,
Richard

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list