Bingo... cygserver-config script installed inconsistent path in registry.

Corinna Vinschen corinna-cygwin@cygwin.com
Mon Mar 24 16:41:00 GMT 2014


On Mar 21 16:03, Linda Walsh wrote:
> Finally tracked this down.
> 
> when I ran the cygserver-config, it installed a different
> path for cygserver-config than what everything else
> thinks it is running under...
> 
> I.e. even though my shell and the dbus server, both think
> they are running under C:/bin (which is a symlink ->
> cygwin64/bin, through C:\windows\system32\cygwin)

Why did you mess around with the install paths that badly?  Don't
install anything Cygwin into C:\windows.

> The cygserver-config installed C:\cygwin64\bin\cygrunsrv.exe
> in the registry -- which worked for starting it, but it thought
> it was a different instance than anything else.
> 
> i.e. bash, and X11 and dbus are all started off of C:\bin.
> 
> I changed the path of the service to correspond to the others
> (->C:\bin\cygrunsrv.exe), and now my X server picks up the shared
> memory.
> 
> (But glxgears still don't turn... -- I thought the lack of shared
> memory might be a problem there, but guess its another problem).
> 
> So why didn't cygserver-config install what all the other progs
> thought they were under ("C:\bin")?

The script just calls cygrunsrv.  cygrunsrv fetches it's own path via
the Win32 API GetModuleFileName and that API returns the path apparently
cleaned from symlinks.


Corinna

-- 
Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20140324/90075e43/attachment.sig>


More information about the Cygwin mailing list