Silently configure sshd fails via system account

Lord Laraby
Mon Mar 17 22:39:00 GMT 2014

I am also having serious issues with sshd-host-config. I ran it right
from the command line, from the built-in administrator account. It
failed to start with no message in the Event Log. But, the
/var/log/sshd.log said none of the keys were properly secured and
refused them all. I chmod'ed them all, tried again, failed again. This
time  it was that /var/empty was wrong. I had just gotten done
installing cygserver, so it was no surprise that cygserver (who had
permission to /var/empty before sshd-host-config) no longer had any
permissions. It was already started, however. So, I check and it was
owned by 'sshd' and group 'Administrator'.

The problem was that the config program never set the required
permissions. The message was "/var/empty must be owned by root and not
group or world-writable." Nice, there is no 'root', so I renamed
Administrator to root. Still no go. So, I changed the permissions to
be very strict (700). You'd think that would fix it?

Nope. So, I thought maybe it wants group 'root', too. So, I renamed
Administrator in /etc/groups to root. Still, not working and same

I then was getting all kinds of weird messages from 'ls' about
group-id conflicts. It's getting worse, I thought. Short of removing
everything and starting over, I rebuilt /etc/passd and /etc/group with
mkpasswd and mkgroup. Then, I changed the owners to sshd again and
group Administrators with mode 600. It fails again.

I thought, "maybe I need to use elevated cygwin, rather than
Administrator account." So, I tried all those steps with that account.
Locked myself out of the /var/empty directory so I had to take
ownership and start all over.

I cannot understand how to do what it wants in order to start. Any
help would be appreciated. I can send cygcheck.out if desired. This is
Windows 8.1 ver 6.3 -- 64-bit. Cygwin (64-bit) is installed in a USB
hard drive K:\cygwin and I recently did an update by running setup and
not selecting anything new. I have run sshd successfully on Win7
computers and older. This is a new one for me.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list