Cygwin needs a man-db port

Erwin Waterlander
Fri Mar 14 14:38:00 GMT 2014

Op 14-3-2014 13:58 Chris J. Breisch schreef:
> Erwin Waterlander wrote:
>> Hi,
>> The major linux distributions have switched for their man system to
>> 'man-db' ( in favour of the classic man.
>> I think that Cygwin should also switch to man-db. man-db is much better
>> in handling man pages in different encoding.
>> Before man-db, libpipeline ( needs to be
>> ported, because man-db uses it.
>> I have tried to port man-db to Cygwin, but I did not succeed. I got
>> stuck in libpipeline. Did anyone else succeed?
>> regards,
>> Erwin
> I downloaded the latest version of libpipeline. It builds fine, but 
> all the tests fail with the following error:
> /usr/src/ports/check/check-0.9.10-1/src/check-0.9.10/src/check_run.c:431: 
> Error in call to timer_create: Invalid argument
> So, I downloaded the source for check. The version of check that we 
> have is a little out-of-date, but at a first glance, the code for 
> timer_create looks okay to me.
> Hmmm...I built check using the cygport file and then went into the 
> tests folder and did a "make check" there. 5 of 6 tests failed and 
> with that exact same error.
> The version of check we have is 0.9.10 from April, 2013. The ChangeLog 
> for 0.9.11 from November of 2013 contains the following:
>     Wed, Nov 4, 2013: Released Check 0.9.11
>       based on r856 (2013-11-04 02:09:21 +0000)
>     * Check compiles for Windows using the Cygwin environment, and all 
> unit tests pass.
> There's also a check 0.9.12 from January of this year.
> It appears to me that we should upgrade check to at least 0.9.11, as 
> I'm unconvinced that the current version is working.

It was in October when I tried. I also could get libpipelines and man-db 
compiled, but it did not work properly. I had also failing tests in the 
libpipeline package. In the end I could display a man page in Russian 
and English of Vim, but man-db coredumped on the Fench man page.

I remember there were indeed problems with 'check'. At that time this 
bug,, was still open. The author 
of man-db suggested to set CK_FORK=no in the environment. That helped 
for several tests, but the first test of libpipelines kept failing.

I also had a problem that I always got static libraries instead of shared.
Even when I explicitly configure with --enable-static=no 


Erwin Waterlander

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list