xwin segfault on latest cygwin snapshot

Marco Atzeri marco.atzeri@gmail.com
Fri Mar 7 17:11:00 GMT 2014


Is it just me seeing the problem on latest snapshots ?

On 01/03/2014 07:45, Marco Atzeri wrote:
> as it works on 1.7.28 I presume it is a snapshot issue
>
> $ uname -srv
> CYGWIN_NT-6.1-WOW64 1.7.29s(0.271/5/3) 20140228 15:31:43
>
>   $ Xwin
> Welcome to the XWin X Server
> Vendor: The Cygwin/X Project
> Release: 1.15.0.0
> OS: CYGWIN_NT-6.1-WOW64 GE-MATZERI-EU 1.7.29s(0.271/5/3) 20140228
> 15:31:43 i686
> OS: Windows 7 Service Pack 1 [Windows NT 6.1 build 7601] (WoW64)
> Package: version 1.15.0-3 built 2014-02-25
>
> winInitializeScreenDefaults - primary monitor w 1600 h 900
> winInitializeScreenDefaults - native DPI x 96 y 96
> Initializing built-in extension Generic Event Extension
> Initializing built-in extension SHAPE
> Initializing built-in extension MIT-SHM
> Initializing built-in extension XInputExtension
> Initializing built-in extension XTEST
> Initializing built-in extension BIG-REQUESTS
> Initializing built-in extension SYNC
> Initializing built-in extension XKEYBOARD
> Initializing built-in extension XC-MISC
> Initializing built-in extension XINERAMA
> Initializing built-in extension XFIXES
> Initializing built-in extension XFree86-Bigfont
> Initializing built-in extension RENDER
> Initializing built-in extension RANDR
> Initializing built-in extension COMPOSITE
> Initializing built-in extension DAMAGE
> Initializing built-in extension MIT-SCREEN-SAVER
> Initializing built-in extension DOUBLE-BUFFER
> Initializing built-in extension RECORD
> Initializing built-in extension DPMS
> Initializing built-in extension Present
> Initializing built-in extension X-Resource
> Initializing built-in extension GLX
> XWin was started with the following command line:
>
> Xwin
>
> (II) xorg.conf is not supported
> (II) See http://x.cygwin.com/docs/faq/cygwin-x-faq.html for more
> information
> LoadPreferences: Loading /home/marco/.XWinrc
> LoadPreferences: Done parsing the configuration file...
> winDetectSupportedEngines - DirectDraw installed, allowing ShadowDD
> winDetectSupportedEngines - Windows NT, allowing PrimaryDD
> winDetectSupportedEngines - DirectDraw4 installed, allowing ShadowDDNL
> winDetectSupportedEngines - Returning, supported engines 0000001f
> winSetEngine - Using Shadow DirectDraw NonLocking
> winScreenInit - Using Windows display depth of 32 bits per pixel
> winWindowProc - WM_SIZE - new client area w: 1584 h: 832
> winFinishScreenInitFB - Masks: 00ff0000 0000ff00 000000ff
> Fatal signal received in thread 0x80000038
> (EE) Segmentation fault at address 0x0
> (EE) Install xorg-server-debuginfo to get symbol table info for backtraces
> Attempting backtrace on pid 3508
> (EE)
> ==================== GDB Backtrace ============
>
>
> ==================== Backtrace ================
>
> ==================== Backtrace End ============
>
> (EE) Fatal server error: (EE) Caught signal 11 (Segmentation fault).
> Server aborting
> (EE) Server terminated with error (1). Closing log file.
> winDeinitMultiWindowWM - Noting shutdown in progress

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list