Shouldn't 'man' depend on 'col'? Shouldn't 'col' be easier to find?

Jack Duthen
Tue Jul 8 15:47:00 GMT 2014

Problem #1:
After I loaded a few cygwin packages, I got this:

$ man bash | wc
man: can't execute col: No such file or directory

The "man" command works perfectly when the stdout is NOT redirected,
but, when sent to a pipe or a file, the command "man" fails with the
above message.

Question #1:
Shouldn't the 'man' function/package depend on the 'col' function/package?

Problem #2
To solve my 'man' problem,I tried to find the 'col' command.

I launched the standard interface (setup.exe) and entered 'col' in the
'Search' text field.

It gave me a list of packages, mainly related to 'colamd', 'colorgc',
'protocol' stuff, 'colored' stuff, 'texlive-collection' stuff,

but no clear link to the missing 'col.exe'.

I tried to put 'col[^A-Za-z]' in the 'Search' text field but it gave nothing.

Question #2:
Shouldn't the 'col.exe' function/package be referenced in some (clear) package?

Problem #3
I googled it and found:
"Cannot locate col command in any current packages" at

whose answer was (in 2002):

"Use this link to find out:"

So I went there, tried to search for 'col', found more than 1000
answers... useless...

Then I searched for '[^A-Za-z]col[^A-Za-z]' and  found 17 matches for
[^A-Za-z0-9_]col[^A-Za-z0-9_], mainly emacs stuff, glpk stuff,
singular-base stuff, texlive-collection stuff and...
the winner is: 'util-linux-2.21-1 - Random collection of Linux
utilities' which contains '/usr/bin/col.exe' among 178 lines.

Question #3
To get a 'man' that works when piped, is there a better way than
loading this "random" collection of utilities?

Am I the only one to get that problem???


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list