[ANNOUNCEMENT] Updated: TeX Live 2014

Ken Brown kbrown@cornell.edu
Mon Jul 7 21:45:00 GMT 2014


On 7/6/2014 3:29 PM, Marco Atzeri wrote:
>
>
> On 04/07/2014 03:34, Ken Brown wrote:
>> On 7/3/2014 4:49 PM, Marco Atzeri wrote:
>>> On 02/07/2014 01:16, Ken Brown wrote:
>>>> Cygwin's TeX Live packages have been updated to the latest upstream
>>>> release, TeX Live 2014.
>>>
>>> Question:
>>> is python3 really a requirement ?
>>
>> I relied on cygport for the requirements, and it found python3 as a
>> requirement for seven of the collections.  I've taken a quick look at a
>> couple of them, and I suspect that python3 shouldn't really be required.
>>   But I'm not sure it's worth the trouble to go carefully through all
>> seven to be sure.
>>
>> Ken
>
> I suggest to review the requirements
> currently on cygwin64 texlive is pulling both python and python3

All of the python3 requirements are bogus, and I'll remove them.  But 
TeX Live contains many python scripts, so certainly some of the packages 
should and do require python.

> I have strong doubts about both, and I do't see why texlive
> should require numpy

See /usr/share/texmf-dist/scripts/pgfplots/pgfplots.py (from 
texlive-collection-pictures).

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list