Maintainer for git?

Adam Dinwoodie adam@dinwoodie.org
Sun Jan 26 19:19:00 GMT 2014


On Sat, Jan 25, 2014 at 04:55:57PM -0800, Balaji Venkataraman wrote:
> On Sat, Jan 25, 2014 at 3:59 AM, Corinna Vinschen wrote:
> > I have a hunch that this is not a OpenSSL but a Cygwin problem.
> >
> > The default case in OpenSSL is to use SSE2 instructions in the x86
> > assembler code.  However, SSE2 instructions utilize the x86 XMM
> > registers, which are not saved and restored in setjmp/longjmp, nor are
> > they stored and restored in signal handling under Cygwin.
> >
> > In the long run Cygwin should save and restore the XMM registers on
> > x86 as well, I guess.
> >
> > For the time being, I've build a new OpenSSL version 1.0.1f-2 with the
> > "no-sse2" flag.  With this version I could clone the linx repo without
> > error.  Please give it a try.
> 
> Thanks Corinna for the openssl updates. I definitely see an
> improvement with them. I was able to clone the ffmpeg repo w/o errors
> - which was not happening earlier.

This is good to hear, particularly given I was unable to reproduce that
problem.

> However, the linux repo clone
> failed w/ the same error as before. Not sure if there is something
> else that could be going on.
> 
> x86$ git clone https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
> linux
> Cloning into 'linux'...
> remote: Counting objects: 3407728, done.
> remote: Compressing objects: 100% (517899/517899), done.
> remote: Total 3407728 (delta 2869094), reused 3399100 (delta 2860672)
> Receiving objects: 100% (3407728/3407728), 713.94 MiB | 619.00 KiB/s, done.
> fatal: pack is corrupted (SHA1 mismatch)
> fatal: index-pack failed

I was previously managing to reproduce this, but since updating to
Corinna's latest OpenSSL builds, I've not had any issues.  Is it
possibly an out-of-date library hanging around in memory?  Have you
tried restarting all your Cygwin processes and/or rebooting your system?
I'm surprised Corinna's changes would fix it for me but not for you.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list