"Bug" in setup-x86.exe command line

Ken Brown kbrown@cornell.edu
Tue Dec 9 18:28:00 GMT 2014

On 12/9/2014 12:07 PM, Kizito Porta Balanyà wrote:
>> Hello,
>>   I use the latest version of the installer setup-x86.exe version 2.852
>> I think that the command line installer has some king of "bug".
>> The following line doesn't download the bash package:
>> setup-x86.exe --download --site
> http://mirrors.kernel.org/sourceware/cygwin  --quiet-mode
> --no-shortcuts --local-package-dir c:\testdir --packages bash
>> Instead the following line does it (csih package):
>> setup-x86.exe --download --site
>> http://mirrors.kernel.org/sourceware/cygwin  --quiet-mode
>> --no-shortcuts --local-package-dir c:\testdir --packages csih
>> I don't understand what is happening. I attache the log files: they
>> seem ok, but in fact the bash package is never downloaded.
>>> You may be misunderstanding what the --download option is supposed to do.
> No, it's not. It is a clean directory , whithout previous interactive
By "It" I assume you mean the local package directory c:\testdir.  But 
you haven't specified a root directory for the install.  So setup 
probably assumed whatever root directory you used in your last Cygwin 
install.  If I'm not mistaken, this information is recorded in the 
registry.  I hope someone will correct me if I'm wrong.

> session and nothing is installed.
>>> I think it's supposed to cause setup to behave as >> >> though you had checked the "Download Without Installing" option in an >> interactive session. So it should download whatever >>packages >> have been selected for installation. In your first run, the only >> package selected was bash, which was already installed, >>so setup had >> nothing to do. In the second run, I assume that you didn't already have csih installed, so setup downloaded it for >>later install.
> I'm only trying to download packages, not installing them.

That may be your intention/expectation, but setup is downloading them 
*for later install*, as I said before.

> Bash is not downloaded, but csih it is (as example). Could you try
> both commands and let me know if it works for you?

I had already tried them before responding to your first message.  In my 
case setup didn't download either bash or csih, presumably because they 
were both already installed (in the Cygwin installation whose root was 
stored in the registry).  On the other hand, I just now tried your first 
command again, but I added "--root c:/foobar".  So I explicitly told 
setup I'm doing a new installation, and this time it did download bash 
(as well as all its dependencies).

I think setup is behaving as designed.


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list