"Bug" in setup-x86.exe command line

Kizito Porta Balanyà kfeina@gmail.com
Tue Dec 9 17:07:00 GMT 2014


> Hello,

>  I use the latest version of the installer setup-x86.exe version 2.852
> I think that the command line installer has some king of "bug".

> The following line doesn't download the bash package:

> setup-x86.exe --download --site
http://mirrors.kernel.org/sourceware/cygwin  --quiet-mode
--no-shortcuts --local-package-dir c:\testdir --packages bash

> Instead the following line does it (csih package):

> setup-x86.exe --download --site
> http://mirrors.kernel.org/sourceware/cygwin  --quiet-mode
> --no-shortcuts --local-package-dir c:\testdir --packages csih

> I don't understand what is happening. I attache the log files: they
> seem ok, but in fact the bash package is never downloaded.

>> You may be misunderstanding what the --download option is supposed to do.

No, it's not. It is a clean directory , whithout previous interactive
session and nothing is installed.

>> I think it's supposed to cause setup to behave as >> >> though you had checked the "Download Without Installing" option in an >> interactive session. So it should download whatever >>packages >> have been selected for installation. In your first run, the only >> package selected was bash, which was already installed, >>so setup had >> nothing to do. In the second run, I assume that you didn't already have csih installed, so setup downloaded it for >>later install.


I'm only trying to download packages, not installing them.

Bash is not downloaded, but csih it is (as example). Could you try
both commands and let me know if it works for you?

Thanks a lot for your time.

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list