fork::abort starting emacs-X11 [ain't no more]

Rockefeller, Harry
Mon Dec 8 15:35:00 GMT 2014

> >-----Original Message-----
> >From: [] On Behalf Of Ken Brown
> >Sent: Friday, December 05, 2014 10:40 AM
> >To:
> >Subject: Re: fork::abort starting emacs-X11

> >On 12/5/2014 9:56 AM, Rockefeller, Harry wrote:
>> I get errors:
>> 0 [main] emacs-X11 6552 child_info_fork::abort: C:\cygwin\bin\cyggnutls-28.dll:
>> Loaded to different address: parent(0x1710000) != child(0x130000)
>> when I start emacs after a PC reboot.  I also notice that none of my dired buffers are recalled.
>> FWIW I have " (desktop-save-mode 1)" in my .emacs file.
>> I shut Cygwin down and started emacs with -Q option, but when I tried
>> to create a dired Buffer it gave the fork error again.
>> Rebaseall procedure works to fix the fork issue - until the next reboot.

>I have no idea what could cause fork problems to disappear after rebaseall and then reappear after a reboot.  Maybe someone else can help.

>I did try to reproduce the problem and couldn't (on both 32-bit and 64-bit Cygwin).  Here's what I tried:

>1. Reboot.

>2. Start the X server using the Start Menu shortcut provided by the latest xinit package, with no ~/.startxwinrc.

>3. In the resulting xterm, 'emacs -Q&'.

>4. 'C-x d' to list the home directory.


I ran setup-x86.exe updating my packages and then started Cygwin.
No fork issues.  Hmmm.
It's hard to believe a lack of carriage return in .Xresources was the problem.
I also removed a useless line: "emacs.font     fixed" before the one I really want
"emacs.font     6x10".   OR  Could BLODA be the cause?
I know my employer updates software automagically in evenings when I'm not here.
Anyway, thanks for looking into this Ken.  I really appreciate you and the rest of
The Cygwin-developer team's work.  No, I *really* appreciate it.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list