Cygwin and lz/lza running out of memory?

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Mon Sep 23 14:43:00 GMT 2013


On 9/23/2013 2:28 AM, Matt D. wrote:
> On 9/22/2013 10:25 PM, Larry Hall (Cygwin) wrote:
>> On 9/22/2013 5:30 PM, Matt D. wrote:
>>> Depending on the options I choose, I keep running into lz/lzma reporting:
>>> "ERROR: Can't allocate required memory!".
>>>
>>> This can occur before or during compression. The lz/lza process tends to
>>> stop after gaining about 400MB on the process; then it exits with this
>>> error. The problem does not appear to be how much available memory I have
>>> but rather q question of why the process can't seem to allocate it.
>>>
>>> Any advice?
>>
>> Take a look at this thread and see if this leads you to an answer.
>>
>> <http://cygwin.com/ml/cygwin/2012-11/msg00104.html>
>>
>> If not, please follow the problem-reporting guidelines found here:
>>
>>> Problem reports:       http://cygwin.com/problems.html
> The link sounded promising but no matter how high I set it (tried up to
> 8192), I get the same error, even when bringing down the compression ratio a
> bit.

I suggest reading through all the posts in the thread, particularly the
recent ones:

<https://sourceware.org/cgi-bin/search.cgi?wm=wrd&form=extended&m=all&s=D&ul=%2Fml%2Fcygwin%2F%25&q=xz%20-9%20%3A%20Cannot%20allocate%20memory>

If you're still having problems, I recommend you update to the most recent
Cygwin DLL if you're not running it already.  If that's still no help, I
point you back to my recommendation about submitting a full problem report
with cygcheck output as described by the link I provided above.

-- 
Larry

_____________________________________________________________________

A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list