Tools can't find ncurses

Warren Young warren@etr-usa.com
Tue Sep 17 01:08:00 GMT 2013


On 9/14/2013 15:48, Thomas Wolff wrote:
> Am 14.09.2013 17:15, schrieb wynfield@gmail.com:
>> checking for working ncurses... no
>> configure: error: Cannot find a curses library.  Perhaps you failed to
>> install an ncurses development package?

You may be able to dig more details out of config.log.  It'll be 
thousands of lines long, and the error is rarely right at the end.  So, 
look for something like "-lncurses" or "curses.h".  The helpful bits in 
that file will be nearby.  (And not necessarily *after* the matching line!)

You're looking for the test program source emitted by the configure 
script and the errors your compiler gave when trying to compile it.

> The files you quoted are the runtime libraries.

Yes, but OP said:

>> and cygcheck displays:
>>      x86/libncurses-devel/libncurses-devel-5.7-18

So, since the development package does seem to be installed, what does 
"cygcheck -c libncurses-devel" say?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list