Build Failure for APR library

wynfield@gmail.com wynfield@gmail.com
Sun Sep 15 13:08:00 GMT 2013


Thanks for the information.  I thought cygwin's httpd version was older.   I downloaded and isntalled it with setup.exe.  But I couldn't get it to run successfully.

I installed it like this:

 $ cygrunsrv -I httpd2 -O -p /usr/sbin/httpd2.exe -e CYGWIN="ntsec tty"

 $ cygrunsrv -S httpd2

  Error: The console displays:
     - cygrunsrv: Error starting a service: QueryServiceStatus:  Win32 error 1062:

   and the eEvent Log Shows:
      1st:  PID 2252: `httpd2' service started.
      2nd:  PID 3356: service `httpd2' failed: signal 12 raised.

 I gave all log files, etc rwx permissions for everthing I could think of, but it still shuts down after starting up.

Regards

---


David Rothenberger
> On 9/14/2013 6:18 AM, wynfield
> > I read that Apache would build on Cygwin out-of-the-box, but found out that isn't the case now if it was before.  Or my setup is wrong.
> > 
> > I wanted to build:
> >   	 Apache    VERS=2.4.6  which is httpd-2.4.6
> > 
> > This requires the two libraries  apr and apr-util
> 
> apr and apr-util libraries are already packaged for Cygwin as
> libapr1-devel and libaprutil1-devel respectively. If you wish to see how
> they are built for Cygwin, you can download the source for the packages
> and look at the cygport build script.
> 
> FYI, apache2 is also available as a pre-built package for Cygwin. You
> can also download its source package to see how it is built.
> 
> -- 
> David Rothenberger  ---- 

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list