Tools can't find ncurses

wynfield@gmail.com wynfield@gmail.com
Sat Sep 14 19:35:00 GMT 2013


VERS: orpie-1.5.1.

./configure  --with-ncurses


checking for working ncurses... no
configure: error: Cannot find a curses library.  Perhaps you failed to install an ncurses development package?


But I do have ncurses as the result from cygcheck shows below:
 ls /bin/*ncurses*
/bin/cygncurses++-10.dll   /bin/cygncurses7.dll     /bin/ncurses6-config
/bin/cygncurses++-8.dll    /bin/cygncurses-8.dll    /bin/ncursesw5-config
/bin/cygncurses++-9.dll    /bin/cygncurses-9.dll    /bin/ncursesw6-config
/bin/cygncurses++w-10.dll  /bin/cygncursesw-10.dll
/bin/cygncurses-10.dll     /bin/ncurses5-config

and cygcheck displays:
    x86/libncurses-devel/libncurses-devel-5.7-18
    x86/libncurses10/libncurses10-5.7-18
    x86/libncurses7/libncurses7-5.3-4
    x86/libncurses7/libncurses7-5.3-4-src
    x86/libncurses8/libncurses8-5.5-10
    x86/libncurses8/libncurses8-5.5-10-src
    x86/libncurses9/libncurses9-5.7-16
    x86/libncurses9/libncurses9-5.7-16-src
    x86/libncursesw-devel/libncursesw-devel-5.7-18
    x86/libncursesw10/libncursesw10-5.7-18

I realize that there is an Orpie already in cygwin's repository, but I need to build it, as I am adding new functionality to it and want to extend it.

If anyone knows why the build tools/scripts can not find the ncurses library and how I can patch it, please let know.

Regards

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list