How to read ntfs_reparse_data

Andrey Repin
Fri Sep 13 23:58:00 GMT 2013

Greetings, Matthias Meyer!

>>>>> I've installed cygwin 1.7.20 on my Windows7 and try to get reparse data
>>>>> of a junction point:
>>>>> getfattr -h -e hex -n system.ntfs_reparse_data
>>>>> /cygdrive/C/Users/Default\ User but I get an error:
>>>>> /cygdrive/C/Users/Default User: system.ntfs_reparse_data: Not supported
>>>>> If I mount the drive in Linux with ntfs-3g it will work. I get:
>>>>> # file: /cygdrive/C/Users/Default User
>>>>> system.ntfs_reparse_data=0x030000a0f00000000000760078006e005c....
>>>>> Anyone knows this "problem"? Is there a(nother) way to get the
>>>>> system.ntfs_reparse_data? Maybee with a windows program?
>>>>> I'ld like to restore a junction point within Linux/ntfs-3g.
>>>> The first four paragraphs.
>>>> TL;DR: You're looking the wrong way.
>>> Thanks for the answer but it doesn't help me ;)
>> Ok, I can give you another answer, more detailed, but I have no idea, how
>> much more usable, as I'm no expert in low-level NTFS specifics.
>> I can imagine Cygwin tools being able to read, store and restore
>> OS-specific file attributes, but I doubt these attributes have any use
>> outside OS. I.e., I was unable to use NTFS junction point under Linux.
> But not me ;)
> If I can get the reparse data of a junction and store it in a backup I'm 
> able to boot a PC into Linux and recreate the junction-point. That's my 
> goal.
>> Junction was to a second partition of the same drive, so there's no
>> possibility of missing partitions or similar mistakes on my part. ntfs-3g
>> just doesn't work the same way, as native Windows NTFS driver.
> Maybee I missunderstood what you are saying. My english isn't well too :)
> But ntfs-3g supports the reparse data. I can read (getfattr) the reparse 
> data and I can create (setfattr) junctions too.
> Unfortunatly it seems that getfattr didn't read the reparse data in cygwin 
> environment.
>> Oh, also... Are you sure you have full low-level access to partition in
>> question? I.e., it is not blocked by antivirus, or UAC?
> No, I'm not sure.

Ok, let me rephrase it - are you trying these commands in an elevated shell?
(i.e. mintty running as administrator.)

> In the meantime I find fsutil.exe and tried:
C:\>> cd \Users\meyer
C:\>> fsutil Cookies
> Error: Access is denied.

> But than I tried:
C:\>> mklink /J test C:\Users\meyer\AppData\Roaming\....\Cookies
C:\>> fsutil test
> and this will work. I get my reparse data :)
> I will see if I can reuse this data with setfattr.

> br
> Matthias

Andrey Repin ( 14.09.2013, <01:51>

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list