iodbc always in error

Sébastien Dailly sebastien@chimrod.com
Thu Sep 5 08:03:00 GMT 2013


Hello,

I'm trying to make iodbc work with cygwin, but I'm always getting errors. 
I've installed « libiodbc2 », « iodbctest », « iodbcadm-gtk » and the 
sqlite driver « odbc-sqlite3 ».

When I wan to check the configuration, I've got the following session :

> $ iodbctest mysqlite
> iODBC Demonstration program
> This program shows an interactive SQL processor
> Driver Manager: 03.52.0812.0326
> 1: SQLDriverConnect = [iODBC][Driver Manager]Driver's SQLAllocEnv() failed 
> (0) SQLSTATE=IM004
> 1: ODBC_Connect = [iODBC][Driver Manager]Driver's SQLAllocEnv() failed (0) 
> SQLSTATE=IM004
> 
> Have a nice day.

The configuration file is here and works when I test it on Debian :

> [ODBC Data Sources]
> mysqlite = SQLite
> 
> [mysqlite]
> Driver      = /usr/lib/cygsqlite3odbc.dll
> Description = My sqlite test database
> Database    = /home/user/databases/mytest.db
> ; optional lock timeout in milliseconds
> Timeout     = 2000
> 
> [ODBC]
> Trace         = 1
> TraceAutoStop = 0
> TraceFile     = sql.log
> Debug         = 1
> DebugFile     = sql_debug.log

I've first suspected something wrong in the sqlite driver and recompiled
it from sources, but I still get the same error, so I now think there is
a problem in the iodbc library.

The iodbc log are here : http://pastebin.com/mzDLUC3x

Can you help me to understand what happen ?

Thanks !

(I'm not registered on the ml, please cc me in your answer.)

-- 
Sébastien
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list