config.guess and config.sub older than new Cygwin64

Charles Wilson cygwin@cwilson.fastmail.fm
Wed Sep 4 22:14:00 GMT 2013


On 9/4/2013 5:43 PM, Earnie Boyd wrote:
> Just a note to those of you using Cygwin64 to build packages.  You
> will need to most likely replace the config.guess and config.sub files
> in those packages with newer ones from
> ftp://ftp.gnu.org/pub/gnu/config/ because it won't guess your system
> correctly.
>
> Twice now I've seen on config-patches a report submitted because of this.
>

The versions installed into /usr/share/automake-X.Y/ have all been 
modified to be the latest upstream as of mid-July -- for all X.Y from 
1.4 to 1.14.

Also, cygport itself ships with an identical copy, and modifying your 
script to call 'gnuconfigize' during src_compile() will update them as well.

--
Chuck



--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list