Cygwin, Windows Shared Drive Access

Tue Mar 26 21:00:00 GMT 2013

On 3/26/2013 10:26 AM, mcforum wrote:
> A new Windows 7 32 system with a fresh install of CYGWIN can't see any mapped
> network or shared drives on my other systems.  On the older XP system IT tells
> me to replace and on another older Windows 7 32 system, CYGWIN could access 
> drives.  What am I missing in the install that enables access to those drives?

As I tried to convey (unsuccessfully) with your original inquiry on the
Cygwin-X list, there isn't a specific Cygwin package that you just install
to make this work.  But you could, of course, look at the list of packages
you have installed on both your new machine and old to make sure that you
have achieved package parity.  If you'd like to do this comparison, you can
use 'cygcheck -cd' to get the list from the new and old systems.  I don't
think doing this will help with the problem at hand but it may be useful
for other reasons.


> The shares don't seem to be shown anywhere on the system tree but I can soft
> link them to a directory name and then access them.
> On a CYGWIN restart "net use" shows the network names as being disconnected 
> reissuing the command doesn't change the status.  However, re-establishing the
> soft link allows full usability.
> Gremlins?

Indeed, those are always possible.  Typically here they take the form of
BLODA (  But I don't think that's the
problem in this case.  Given the steps you outlined above (and I snipped
for brevity) I played around with this some on my systems.  I found I could
get myself into what looked like your situation if I was dealing with a
share with a password.  Once I created a persistent mapping with the
password, everything worked as expected in my Windows session (and any
Cygwin terminal, Cygwin cmd.exe, or Windows cmd.exe windows).  I didn't
try rebooting.  The steps above do not show you supplying passwords but
once I did that for a particular share, I didn't need to use it again to
recreate the share so I'm wondering if your shares do require passwords
too.  If so, then what I'm seeing may match yours and you may find that
deleting the existing shares and recreating them persistently with the
passwords will help.

-- Larry

Everything is under the same network domain password with my user as the owner.  

Tried the brute force method of doing a network copy of the working Cygwin on 
the older Windows 7 system to the new.  It worked as expected.  Switched back to 
the newer version and it is now working.  After a restart it is still working.

rm3@McBroomRC4 ~
$ net use
New connections will be remembered.

Status       Local     Remote                    Network
OK           J:        \\oro-fbbe-fs1nts\apps_client
                                                Microsoft Windows Network
OK           N:        \\oro-fbbe-fs1nts\se_cmn  Microsoft Windows Network
OK           S:        \\oro-fbbe-fs1nts\oro_cmn Microsoft Windows Network
OK           T:        \\Mcbroomrc2\e            Microsoft Windows Network
OK           U:        \\oro-fbbe-fs1nts\rm3     Microsoft Windows Network
OK           W:        \\Mcbroomrc2\mcrc2        Microsoft Windows Network
The command completed successfully.

rm3@McBroomRC4 ~

Thanks for your efforts.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list