emacs-X11 crashes under gdb in recent snapshots

Ken Brown kbrown@cornell.edu
Wed Mar 6 21:30:00 GMT 2013

Starting with the 20130102 snapshot, I get a SEGV if I run emacs-X11 
under gdb.  The same thing happens with emacs-w32, but not with 
emacs-nox.  In the case of emacs-X11, it doesn't matter whether I run it 
in mintty or under an X server.  It happens with emacs-24.2-1 as well as 
with later test versions (and builds from the emacs trunk).

To reproduce:

1. Install emacs-X11-24.2-1 and emacs-debuginfo-24.2-1.

2. Start emacs under mintty.

3. In a separate mintty, attach gdb to it and try to continue:

$ ps | grep emacs
      5328   10484    5328      10188  pty0    1003 16:16:33 

$ gdb -p 5328
GNU gdb (GDB) (cygwin-special)
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later 
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-cygwin".
For bug reporting instructions, please see:
Attaching to process 10188
[New Thread 10188.0x2a88]
[New Thread 10188.0x1e64]
[New Thread 10188.0xaec]
[New Thread 10188.0x21a8]
[New Thread 10188.0x2990]
[New Thread 10188.0xbbc]
Reading symbols from /usr/bin/emacs-X11.exe...Reading symbols from 
(gdb) c

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 10188.0x1e64]
0x00000030 in ?? ()

In the 20130102 snapshot, it takes a few seconds after typing `c' before 
the crash occurs.  In more recent snapshots, it happens immediately.


Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list