Shouldn't gcc-4 depend on libmpfr4 ?

Yaakov (Cygwin/X) yselkowitz@users.sourceforge.net
Tue Mar 5 09:54:00 GMT 2013


On Tue, 5 Mar 2013 09:18:04 +0000 (UTC), Achim Gratz wrote:
> The remaining problem is that the library version changes from
> cyggmp-3 to cyggmp-10.  Not sure how to deal with that or if the new
> package should just be libgmp10 instead of libgmp3 (I have the same
> problem with mpc, the old way of forcing the version doesn't work there
> anymore).

As packagers, we shouldn't be messing around with DLL version numbers
unless a mistake has clearly been made and confirmed upstream.  Correct
version bumps means ABI incompatibilities, so you can't just force back
the version without breaking existing software already built against
the old version.


Yaakov


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list