texlive-install: core dumped

Helmut Karlowski helmut.karlowski@ish.de
Sat Jun 29 12:36:00 GMT 2013


Ken Brown, 29.06.2013 13:42:49:

>> I don't know which process crashed
>
> The error message suggests that the following crashed:

I also think so, but it does not crash when run manually.

>    luatex -ini  -jobname=luatex -progname=luatex luatex.ini
>
> Can you run it by hand (as administrator)?

Sure - no crash.

>> With fmtutil --all I get at the end:
>>
>> ###############################################################################
>>
>> fmtutil: Error! Not all formats have been built successfully.
>> Visit the log files in directory
>>    /home/adm/.cache/texmf/web2c
>> for details.
>> ###############################################################################

Just noticed I always had this message (found in an old logfile from 2011).

> Have you installed texlive-collection-formatsextra?  If not, I think  
> this is to be expected.  In any case, it can be ignored unless you use  
> mltex.
>
>> `xetex -ini  -jobname=xetex -progname=xetex -etex xetex.ini' failed
>> `xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini'  
>> failed
>
> Have you installed texlive-collection-xetex?

I think I have them all, as controlled by default-setup.

With

fmtutil-sys --all &>~/fmtutil.log

There's also no crash.

But there are some issues - e.g.:


fmtutil: running `pdftex -ini   -jobname=amstex -progname=amstex  
-translate-file=cp227.tcx *amstex.ini' ...
This is pdfTeX, Version 3.1415926-2.5-1.40.14 (TeX Live 2013/Cygwin)  
(INITEX)
  restricted \write18 enabled.
  (/usr/share/texmf-dist/web2c/cp227.tcx)
entering extended mode
(/usr/share/texmf-dist/tex/amstex/config/amstex.ini
(/usr/share/texmf-dist/tex/plain/base/plain.tex
Preloading the plain format: codes, registers, parameters, fonts, more  
fonts,
macros, math definitions, output routines, hyphenation
(/usr/share/texmf-dist/tex/generic/hyphen/hyphen.tex)) (/bin/amstex
! Missing $ inserted.
<inserted text>
                 $
<to be read again>
                    ^^A
l.1 ...^^@^^@^^@^^@^^@^^@^^@^^N^^_º^^N^^@Ž Í!ž^^A
                                                   LÍ!This program cannot  
be ...

?
! Emergency stop.
<inserted text>
                 $
<to be read again>
                    ^^A
l.1 ...^^@^^@^^@^^@^^@^^@^^@^^N^^_º^^N^^@Ž Í!ž^^A
                                                   LÍ!This program cannot  
be ...

No pages of output.
Transcript written on amstex.log.
Error: `pdftex -ini  -jobname=amstex -progname=amstex  
-translate-file=cp227.tcx *amstex.ini' failed

And more.


It would be really helpful to be able to find the stackdumps produced  
during setup. I don't care that much about the TeX-errors.


-- 
Helmut Karlowski

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list