texlive-install: core dumped

Ken Brown kbrown@cornell.edu
Sat Jun 29 12:26:00 GMT 2013


On 6/29/2013 6:34 AM, Helmut Karlowski wrote:
> I've just updated my cygwin using setup.exe on XP-pro and found that the
> texlive-install produced an error.
>
> In setup.log.full I found:
>
> fmtutil: initial config file is `/etc/texmf/web2c/fmtutil.cnf'
> fmtutil: configuration file updated: `/etc/texmf/web2c/fmtutil.cnf'
> fmtutil: running `luatex -ini   -jobname=luatex -progname=luatex
> luatex.ini' ...
> Memory fault (core dumped)
> Error: `luatex -ini  -jobname=luatex -progname=luatex luatex.ini' failed
>
> ...
>
> fmtutil: initial config file is `/etc/texmf/web2c/fmtutil.cnf'
> fmtutil: configuration file updated: `/etc/texmf/web2c/fmtutil.cnf'
> fmtutil: running `luatex -ini   -jobname=dviluatex -progname=dviluatex
> dviluatex.ini' ...
> Memory fault (core dumped)
> Error: `luatex -ini  -jobname=dviluatex -progname=dviluatex
> dviluatex.ini' failed
>
> ...
>
> fmtutil: running `luatex -ini   -jobname=luatex -progname=luatex
> luatex.ini' ...
> Memory fault (core dumped)
> Error: `luatex -ini  -jobname=luatex -progname=luatex luatex.ini' failed
>
> and more.
>
> I don't know which process crashed

The error message suggests that the following crashed:

   luatex -ini  -jobname=luatex -progname=luatex luatex.ini

Can you run it by hand (as administrator)?

> Are the stackdumps being deleted by setup? I could not reproduce a crash
> by running fmtutil --refresh manually.

'fmtutil --refresh' just recreates existing formats, so it shouldn't 
fail.  And, by the way, you should have been running fmtutil-sys rather 
than fmtutil if you're trying to reproduce what the texlive postinstall 
scripts do.

> With fmtutil --all I get at the end:
>
> ###############################################################################
>
> fmtutil: Error! Not all formats have been built successfully.
> Visit the log files in directory
>    /home/adm/.cache/texmf/web2c
> for details.
> ###############################################################################
>
>
> This is a summary of all `failed' messages:
> `pdftex -ini  -jobname=mllatex -progname=mllatex
> -translate-file=cp227.tcx -mltex mllatex.ini' failed

Have you installed texlive-collection-formatsextra?  If not, I think 
this is to be expected.  In any case, it can be ignored unless you use 
mltex.

> `xetex -ini  -jobname=xetex -progname=xetex -etex xetex.ini' failed
> `xetex -ini  -jobname=xelatex -progname=xelatex -etex xelatex.ini' failed

Have you installed texlive-collection-xetex?

Ken

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list