libmpfr4 3.1.2-1 broken (experimental)

Achim Gratz Stromeko@nexgo.de
Tue Jun 25 03:10:00 GMT 2013


JJ Hawkins writes:
> When building something (znc in the example below) this occures with
> libmpfr4 3.1.2-1.
>
> libmpfr4 3.0.1-1 (experimental) is not broken.

For the record: at the moment version 3.0.1 is current, and 3.1.2 is
test/experimental for use with gcc-4.7.2.

> $ make
> Building core object main...
> /usr/lib/gcc/i686-pc-cygwin/4.7.2/cc1plus.exe: error while loading
> shared libraries: ?: cannot open shared object file: No such file or
> directory
> Makefile:100: recipe for target `src/main.o' failed
> make: *** [src/main.o] Error 1

You need to install the test versions for _all_ gcc-4.7.2 dependencies,
specifically these libraries:

gmp, mpfr, mpclib, ppl, cloog-ppl

If you miss to install some of them you'll get an error like the above
(if you're lucky).  Conversely, the test libraries do _not_ work when
trying to use them with gcc-4.5.3.


Regards,
Achim.
-- 
+<[Q+ Matrix-12 WAVE#46+305 Neuron microQkb Andromeda XTk Blofeld]>+

Wavetables for the Terratec KOMPLEXER:
http://Synth.Stromeko.net/Downloads.html#KomplexerWaves


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list