Problems with file permissions during a build

Corinna Vinschen
Fri Jun 21 13:19:00 GMT 2013

On Jun 21 14:38, Arjen Markus wrote:
> I noticed that if I use noacl, then I get the correct looking POSIX permissions,
> but the Windows permissions make it impossible to use the file.

I always use "acl" as mount option.

> Try: cat gnulliver.h

  $ pwd
  $ cat src/include/gnulliver.h

> I have had the same problem with a package built via autotools, so it
> is more general
> than CMake. (I first reported this on the CMake list, but they did not
> know the solution)
> I run it on /cygdrive/d, which is my Windows d-disk.

Ok, so I tried under /cygdrive/c and the result is the same, then I
tried under an explicit noacl mount point and the result is still the
same.  The file has always enough permissions and reading it is no
problem at all.

But the default Windows permissions on the parent dir of your build dir
could explain that behavior when using the noacl mount option.  Noacl
means, just let Windows do what it always does and fake the permissions
rather than evaluating them from the given ACL.  Remount again with "acl",
and change the permissions explicitely:

  $ chown -R you.your-group .
  $ chmod -R u+rw,go+r .

Also, make sure your umask is set to a useful value:

  $ umask 22


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Maintainer                 cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list