git svn fork() problems on cygwin 1.7.20

Adam Dinwoodie
Mon Jun 17 15:18:00 GMT 2013

Mikko Rapeli wrote:
> On Mon, Jun 17, 2013 at 05:00:47PM +0300, Mikko Rapeli wrote:
>> Has anyone else seen these when using git svn or other perl programs
>> on cygwin 1.7.20?
> <snip>
>> $ git svn rebase
>> ...
>>       0 [main] perl 4424 child_info_fork::abort: address space needed by '_Client.dll' (0x520000) is already occupied
> Hmm. Searching for clues I saw this
> and tried out with minimal PATH:
> $ PATH=/bin:/usr/bin git svn rebase
> Current branch master is up to date.
> Default PATH on the machine includes various tools, compilers, CMake etc.
> Tried to bisect it but it seems that full long PATH has an 80% failure rate
> while mimal PATH=/bin/usr/bin has a 20% failure rate, but I could not identify
> which PATH component could be to blame.
> Somehow PATH is related to this but maybe it's just a side effect.

Two possible guesses: you've multiple cygwin1.dll files in your PATH, or you
just need to rebase (run `rebaseall` from a shell and follow the instructions).
If that doesn't help, follow the problem reporting guidelines:

> Problem reports:

Adam Dinwoodie

Messages posted to this list are made in a personal capacity.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list