Windows 8 permissions broken after a reboot

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Mon Jun 17 03:11:00 GMT 2013


On 6/16/2013 9:13 AM, Simon Majou wrote:
> Hello,
>
> My computer rebooted last night and now sshd doesn't work. The service
> doesn't start anymore.
>
> I tried :
>
> $ cygrunsrv -R sshd
> cygrunsrv: Error removing a service: OpenSCManager:  Win32 error 5:
> Accâ–’s refusâ–’.
>
> (that's access denied)
>
> I re installed cygwin, but I got :
>
> $ ssh-host-config -y
>
> *** Warning: Running this script typically requires administrator privileges!
> *** Warning: However, it seems your account does not have these privileges.
> *** Warning: Here's the list of groups in your user token:
>
>      Utilisateurs
>      HomeUsers
>
>
> And while my user is Administrator in Windows, in cywin I got :
>
> $ id
> uid=1001(simon) gid=545(Utilisateurs) groupes=545(Utilisateurs),1002(HomeUsers)

Did you start whatever your terminal program is with "Run as Administrator"
(I'm not sure how this is translated in the French version of Windows).
Remember, in Windows, even when your account is a member of the
Administrator group, it does not have those permissions by default.
You have to ask for the elevated permission with "Run as Administrator".

> I tried to update the /etc/passwd to assign my user the Admin group
> (as I have in Windows), but then I got :

Don't do this.  It isn't necessary and may cause you trouble in the future.


-- 
Larry

_____________________________________________________________________

A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list