Windows 8 permissions broken after a reboot

Simon Majou
Sun Jun 16 13:13:00 GMT 2013


My computer rebooted last night and now sshd doesn't work. The service
doesn't start anymore.

I tried :

$ cygrunsrv -R sshd
cygrunsrv: Error removing a service: OpenSCManager:  Win32 error 5:
Acc▒s refus▒.

(that's access denied)

I re installed cygwin, but I got :

$ ssh-host-config -y

*** Warning: Running this script typically requires administrator privileges!
*** Warning: However, it seems your account does not have these privileges.
*** Warning: Here's the list of groups in your user token:


And while my user is Administrator in Windows, in cywin I got :

$ id
uid=1001(simon) gid=545(Utilisateurs) groupes=545(Utilisateurs),1002(HomeUsers)

I tried to update the /etc/passwd to assign my user the Admin group
(as I have in Windows), but then I got :

*** Query: Should privilege separation be used? (yes/no) yes
*** Warning: The owner and the Administrators need
*** Warning: to have .w. permission to /var/run.
*** Warning: Here are the current permissions and ACLS:
*** Warning:     drwxrwxrwx+ 1 simon simon 0 16 juin  15:06 /var/run
*** Warning:     # file: /var/run
*** Warning:     # owner: simon
*** Warning:     # group: simon
*** Warning:     user::rwx
*** Warning:     group::rwx
*** Warning:     group:Système:rwx
*** Warning:     group:Administrateurs:rwx
*** Warning:     mask:rwx
*** Warning:     other:rwx
*** Warning:     default:user::rwx
*** Warning:     default:group::r-x
*** Warning:     default:other:r-x
*** Warning:


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list