pty issue causes 'screen' to hang when run from mintty as detached

Andy Koppe andy.koppe@gmail.com
Fri Jun 14 11:57:00 GMT 2013


On 11 June 2013 01:51, Andrew Schulman wrote:
>> See here for additional information and reproducible steps in the mintty
>> support ticket:
>> https://code.google.com/p/mintty/issues/detail?id=390
>>
>> I can reproduce this using cygwin 1.7.20, 1.7.19, 1.7.18, 1.7.15, and 1.7.7.
>>
>> Screen does NOT hang when is is created by calling the first command
>> through cygwin started by cygwin.bat (commands typed through Windows
>> terminal 'cmd.exe' instead of mintty) and then attempting to attach
>> through mintty with the second command.
>>
>> Workaround is to use:
>>
>> 'cygstart --hide screen -S name -d -m'
>
> I get a little different result:
>
> $ screen -S scrn -d -m
> $ screen -S name -x
> Remove dead screens with 'screen -wipe'.
> $
>
> and then I have to run 'reset' to get input echoing back.
>
> I've never observed this behavior before, because I always start screen as
> 'screen -AURD', which works fine.
>
> Do we have any idea whether the problem is with mintty or with screen?

I observed the same behaviour as the OP, but also reproduced it in
rxvt and xterm, so not a mintty issue. Since it works in a console,
the Cygwin pty layer has to be the main suspect, unless screen has
specfic code for Cygwin consoles or ptys?

Andy

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list