python 2.7 module binascii not found

Omar Balbuena balbuena@gmail.com
Sat Jun 1 14:45:00 GMT 2013


Yaakov (Cygwin/X <yselkowitz <at> users.sourceforge.net> writes:

> 
> On 2013-04-25 13:39, lothar atheling wrote:
> > i have newly installed cygwin python 2.7 (python-2.7.3-1) where i
> > formerly used python 2.6.5.
> >
> > my programs with "import urllib" now crash.
> >
> > module urllib wants module base64 which wants module binascii.
> >
> > there is no /usr/lib/python2.7/binascii.py
> > but there is /usr/lib/python2.7/lib-dynload/binascii.dll
> >
> > what can i do to fix this?
> 
> The binascii module depends on zlib but, according to your cygcheck 
> output, you do not have it installed.  Re-run setup.exe, choose the 
> Install from Internet option, and allow it to install all missing 
> dependencies.
> 
> Yaakov
> 
> 


I do have zlib installed and I have the same problem.

zlib                      1.2.8-1              OK
zlib-devel                1.2.8-1              OK
Empty package zlib0
zlib0                     1.2.8-1              OK

Ekevoo@Anas ~/queue
$ python
Python 2.7.3 (default, Dec 18 2012, 13:50:09)
[GCC 4.5.3] on cygwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import binascii
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: No such file or directory
>>>



--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list