startxwin started bash does not read .bashrc or .bash_profile

Kevin Layer
Wed Feb 27 17:59:00 GMT 2013

Jon TURNEY wrote:

>> On 27/02/2013 00:08, Kevin Layer wrote:
>> > If I put this into .startxwinrc:
>> > 
>> >   mintty /usr/bin/bash.exe --login -i
>> > 
>> > the resulting shell does not read .bash_profile.  If I put 
>> > 
>> >   mintty /usr/bin/bash.exe -i
>> > 
>> > it doesn't read .bashrc.
>> I've tried to reproduce this, but it seem to work ok for me.
>> How can are you checking if ~/.bashrc has been read? Have you tried using bash
>> -v to check what bash is reading?

I know ~/.bashrc hasn't been read because my prompt is not changed and
my aliases are not there.

>> This is also a really odd place to start mintty.  Why start it as a side
>> effect of the unrelated action starting the X server?

This is merely an example, the simplest one to reproduce the failure.
It's not how I want to use startxwin.

>> > My ultimate goal is to use ssh-agent/ssh-add to make life easier, but
>> > it requires my .bashrc to be sourced (.bash_profile merely sources
>> > .bashrc).
>> If you are going to work with both mintty and X clients, which will not
>> naturally have a common parent ssh-agent process to inherit from, you might
>> want to investigate the keychain package.

I'm unfamiliar with that.  Thanks for the pointer.


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list