Rebase problems in Ruby

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Mon Feb 25 14:44:00 GMT 2013


On 2/25/2013 12:17 AM, Chloe wrote:
> I'm trying to run 'rails console' in an app with many, many gems (not a test
> app) and it is giving me these errors. I've already tried to run 'rebaseall'
> with ash and I also ran 'rubyrebase' using a script I found on this list
> archive. Neither helped. I've tried several times. 'cygcheck -c' says
> everything's OK. These are the errors I'm getting:
>
>
>
> $ rails console
>        2 [main] ruby 4216 child_info_fork::abort:
> C:\cygwin\bin\cygpixman-1-0.dll: Loaded to different address:
> parent(0x692B0000) != child(0x17A0000)

So where are these gems coming from and how many are there?  Too
many/ones from unknown places are going to be either missed
by 'rubyrebase' or be impossible to fit in memory without
collision with other installed DLLs.  See this thread for more
discussion of this:

<http://cygwin.com/ml/cygwin/2013-01/msg00317.html>

-- 
Larry

_____________________________________________________________________

A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list