1.7.7 on Windows 7: can't write to removable disk

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Thu Feb 21 23:07:00 GMT 2013

On 2/21/2013 5:55 PM, Latchen McKinney wrote:
>> On Jan 11 15:55, Corinna Vinschen wrote:
>>> On Jan 11 15:51, Corinna Vinschen wrote:
>>>> On Jan 10 10:40, tomas@datasupporten.se wrote:
>>>>> Hello.
>>>>> I'm trying to write a disk image to a compact flash card with dd, but I
>>>>> get the error:
>>>>> "dd: writing to /dev/sdj: Permission denied"
>>>>> Apart from the CF-card, I also tried a USB-stick with the same results.
>>>>> I'm logged in as administrator.
>>>> Please have a look into http://support.microsoft.com/kb/942448 first.
>>>> [...listening "De-Loused In The Comatorium" while waiting...]
>>>> Finished reading?  Ok.
>>>> That's quite a serious restriction starting with Vista.  If I destroy the
>>>> filesystem on one of my sd cards under Linux, I can then overwrite it
>>>> with dd under Cygwin.  However, if that dd call created a valid
>>>> filesystem on the sd card, the next write fails again.  For some reason
>>>> it does not help to unmount the filesystem on the drive via the "Disk
>>>> Management" MMC snap-in, despite the claim in the aforementioned
>>>> article.
>>>> The solution I just checked in to Cygwin is rather complicated, but
>>>> I really tested this a couple of hours now, and I didn't find any
>>>> other solution.
>>> I forgot the disclaimer:
>>>    Please test the next developer snapshot from http://cygwin.com/snapshots/
>> Update:  I checked in a revised version of the patch.
>> The code from yesterday tried to lock all partitions at open() time at
>> once, which is hardly minimal-invasive.  It would even try to lock all
>> partitions if you just overwrite the boot sector.
>> With the new code, a partition lock is only triggered on-demand.  As
>> soon as a write() call fails with "Access denied", it searches the
>> partition table for a partition which overlaps with the current write
>> position and then tries to lock only that partition.
> Hello!
> I am curious if this patch was included in the live build of cygwin.  I use dd for archiving and making new copies of floppy disks from images, and I can no longer do that in Windows 7.  I, too, get the error message:
> "dd: writing to /dev/fd0: Permission denied"

Cygwin 1.7.7 is very old and the thread you reference is over 2 years
old.  The current version of Cygwin is 1.7.17.  If you're not up-to-date,
try updating.  If you are and you're having problems, please read and
follow the problem reporting guidelines found at the link below for
any follow-up to this list.

> Problem reports:       http://cygwin.com/problems.html



A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list