Mercurial problems with Python 2.7

Graham Borland graham.borland@gramboid.com
Wed Feb 20 21:08:00 GMT 2013


Cygwin has recently updated the Python version to 2.7.3-1. Since
accepting this upgrade, Mercurial no longer works. Mercurial is at
version 2.4.2-1.

It looks as if Mercurial has hardwired references to Python 2.6, or
something. This is what I get:

graham@teapot /cygdrive/c/Users/graham
$ which hg
/usr/local/bin/hg

graham@teapot /cygdrive/c/Users/graham
$ hg --version
Traceback (most recent call last):
  File "/usr/local/bin/hg", line 38, in <module>
    mercurial.dispatch.run()
  File "/usr/local/lib/python2.6/site-packages/mercurial/dispatch.py",
line 27,                                                   in run
    sys.exit((dispatch(request(sys.argv[1:])) or 0) & 255)
  File "/usr/local/lib/python2.6/site-packages/mercurial/dispatch.py",
line 40,                                                   in dispatch
    req.ui = uimod.ui()
  File "/usr/local/lib/python2.6/site-packages/mercurial/ui.py", line
43, in __i                                                  nit__
    for f in scmutil.rcpath():
  File "/usr/local/lib/python2.6/site-packages/mercurial/scmutil.py",
line 430,                                                   in rcpath
    _rcpath = osrcpath()
  File "/usr/local/lib/python2.6/site-packages/mercurial/scmutil.py",
line 402,                                                   in
osrcpath
    path = systemrcpath()
  File "/usr/local/lib/python2.6/site-packages/mercurial/scmutil.py",
line 455,                                                   in
systemrcpath
    path.extend(rcfiles(os.path.join(p, root)))
  File "/usr/local/lib/python2.6/site-packages/mercurial/scmutil.py",
line 440,                                                   in rcfiles
    for f, kind in osutil.listdir(rcdir)
  File "/usr/local/lib/python2.6/site-packages/mercurial/demandimport.py",
line                                                   86, in
__getattribute__
    self._load()
  File "/usr/local/lib/python2.6/site-packages/mercurial/demandimport.py",
line                                                   58, in _load
    mod = _origimport(head, globals, locals)
ImportError: No such file or directory


How can I get Mercurial up and running again quickly?

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list