Setup 2.774 texlive postinstall takes 10+ hours (resending due to cygwin bounce)

Ken Brown kbrown@cornell.edu
Tue Feb 5 16:43:00 GMT 2013


On 2/5/2013 10:48 AM, jeremycraven wrote:
> I am just reinstalling cygwin on a fresh install of XP on a rather old laptop
> with Avast as virus software.
>
> It is absolutely crawling at the texlive postinstallation stage - stuck
> showing 24-25% for at least half an hour now. I was about to give up but
> googled "cygwin install hangs texlive-collection" and was surprised to
> actually hit something so will leave it to run over night.

The texlive-collection-* postinstall scripts have to do a lot of work, 
and it takes time.  You didn't say which of these packages you've 
installed.  There are almost 100 of them, and most TeX users only need a 
few.  See the announcement at

   http://cygwin.com/ml/cygwin-announce/2012-07/msg00013.html

for some advice.

> Previous installs went a lot lot quicker.
>
> There is no /var/log/setup.log etc that I can see yet ( only an empty file
> setup.log.postinstallXa03208 in C:\cygwin\var\log).

The log files will be available when setup.exe finishes.  Please look at 
them and see if there's anything interesting to report.

> I can confirm kpsewhich.exe is taking most of the CPU.

Not surprising.

Ken


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list