Using jhbuild on cygwin

Jonas Platte jonasplatte@myopera.com
Mon Feb 4 14:31:00 GMT 2013


On 02/04/13 13:57, marco atzeri wrote:
> On 2/4/2013 2:42 PM, Jonas Platte wrote:
>
> Jonas,
> probably you should start with a simpler package than jhbuild
> to learn the basics
>
>> I reinstalled libpng-devel and libxft-devel but that didn't change
>> anything.
>> Okay so here's the same thing with the whole output in english:
>>
>> $ jhbuild sysdeps --install
>> W: glib has a dependency on unknown "gvfs" module
>> W: gtk+ has a dependency on unknown "at-spi2-atk" module
>> W: libproxy has a dependency on unknown "NetworkManager" module
>> W: WebKit has a dependency on unknown "at-spi2-core" module
>> W: dbus-glib has a dependency on unknown "dbus" module
>> W: geoclue has a dependency on unknown "NetworkManager" module
>> W: libgnome-keyring has a dependency on unknown "dbus" module
>> W: gypsy has a dependency on unknown "bluez" module
>> W: glib-networking has a dependency on unknown
>
> looks on available package
> http://cygwin.com/packages/
> for similar naming scheme
As I wrote before, this shouldn't be a problem. I think those are 
jhbuild modules and not cygwin packages.

>
>> "gsettings-desktop-schemas" module
>> Package 'libpng' has no Name: field
>> System installed packages which are new enough:
>>      gnutls (gnutls.pc, required=2.12.8, installed=3.1.4)
>>      libjpeg
>>      pixman (pixman-1.pc, required=0.20.2, installed=0.28.0)
>>      libtiff
>>      libxml2 (libxml-2.0.pc, required=2.8.0, installed=2.9.0)
>>      zlib (zlib.pc, required=1.0, installed=1.2.7)
>>      libtasn1 (libtasn1.pc, required=2.2, installed=3.1)
>>      bison (required=2.0)
>>      flex (required=2.0)
>>      libproxy (libproxy-1.0.pc, required=0.4.7, installed=0.4.11)
>>      libffi (libffi.pc, required=3.0.0, installed=3.0.11)
>> Required packages:
>>    System installed packages which are too old:
>>      (none)
>>    No matching system package installed:
>>      python-devel (python.pc, required=2.5)
>
> as python.pc does not exist you have two
> choice:
> - you teach your build system to ignore/change this requirement
> - you fake one to fool the build system
>
jhbuild lets me ignore the deps, so that should work. Probably most of 
my problems are in the building process anyway, I just wanted to try to 
fix these errors to make sure that the problems are not caused by 
missing depencies. I'm just trying to build gtkmm, there really should 
be no need for python.

>>      libXft (xft.pc, required=2.0.0)
>
> Strange we have 2.3.1:
>
> $ cat /usr/lib/pkgconfig/xft.pc
> prefix=/usr
> exec_prefix=/usr
> libdir=${exec_prefix}/lib
> includedir=${prefix}/include
>
> Name: Xft
> Description: X FreeType library
> Version: 2.3.1
> Requires: xproto
> Requires.private: xrender, fontconfig, freetype2
> Cflags: -I${includedir}
> Libs: -L${libdir} -lXft
The output is the same on my system.

> check on the logs why the build system does not like it.
I didn't find any in /var/log or the user dir. And jhbuilder --help only 
shows how to log the build process, not the sysdeps thing.

>
>>      libpng (libpng.pc)
>> Optional packages: (JHBuild will build the missing packages)
>>    System installed packages which are too old:
>>      (none)
>>    No matching system package installed:
>>      libxslt (libxslt.pc, required=1.1.26)
>>      cairo (cairo.pc, required=1.10.2)
>>      fontconfig (fontconfig.pc, required=2.8.0)
>
> $ cat /usr/lib/pkgconfig/fontconfig.pc
> prefix=/usr
> exec_prefix=/usr
> libdir=${exec_prefix}/lib
> includedir=${prefix}/include
> sysconfdir=/etc
> localstatedir=/var
> PACKAGE=fontconfig
> confdir=${sysconfdir}/fonts
> cachedir=${localstatedir}/cache/${PACKAGE}
>
> Name: Fontconfig
> Description: Font configuration and customization library
> Version: 2.10.1
> Libs: -L${libdir} -lfontconfig
> Libs.private:  -lexpat   -lfreetype -lz -lbz2
> Cflags: -I${includedir}
>
> probably missing this packages:
>
> $ cygcheck -f /usr/lib/pkgconfig/fontconfig.pc
> libfontconfig-devel-2.10.1-1
>
> $ cygcheck -f /usr/lib/pkgconfig/cairo.pc
> libcairo-devel-1.12.8-1
>
> $ cygcheck -f /usr/lib/pkgconfig/libxslt.pc
> libxslt-devel-1.1.27-1
>
libxslt-devel is the only one I hadn't installed. I installed it and 
reinstalled the other ones. But again, nothing changed.
>
>> jhbuild sysdeps: Don't know how to install packages on this system
>>
>
>
>
>
> -- 
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>


--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list