Rsync stops with time-out: solved

Richard Ivarson
Fri Oct 26 10:18:00 GMT 2012

Just in case other Cygwin users also have this problem, I'd like to describe 
a solution.

The Problem was this:

* Run "rsync" on two Windows XP computers communicating to each other 
directly via the (TCP) network.
Example: Source computer uses rsync to sync several folders with many files 
to a destination computer where a rsync background process is running 
(started via "rsync --daemon").
* After syncing a while there's always a time-out (not always at the same 
file however) and both rsync programs stop to transfer any data. Even a rsync 
started with "-vv" parameter for verbose output doesn't show any progress 

* I tried to encircle the problem (see here for example: ) but found no 
solution whatsoever.

a) The direct TCP network communication failed for my two rsync programs all 
the time but on different parts of the synchronisation.

b) Then I tried the other variant of Rsync: a remote-shell program as 
transport. You start a SSH background process on the destination machine 
(named "sshd" in Cygwin's sbin folder) and then run rsync on the source 
computer with single colon URLs instead of two colons as in variant a). 
Please see Rsync manual:

"There are two different ways for rsync to contact a remote system: using a 
remote-shell program as the transport (such as ssh or rsh) or contacting an 
rsync daemon directly via TCP. The remote-shell transport is used whenever 
the source or destination path contains a single colon (:) separator after a 
host specification. Contacting an rsync daemon directly happens when the 
source or destination path contains a double colon (::) separator after a 
host specification, OR when an rsync:// URL is specified..."

So, with the ssh variant rsync works now fine on my machines. If anybody else 
has these problems of a) too, maybe variant b) works for you, too?

P.S. Since I'm no network expert at all, does anybody have an idea why 
variant a) doesn't work, but variant b) work well? It's a mystery to me.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list