Passwordless authentication between two domains.

Wed Nov 28 18:38:00 GMT 2012

I am still getting the same error. And permissions are all good. When i run SSHD in debug i get this? Has anyone encountered this issue before.

bash-3.2# /bin/sshd.exe -D -ddd -e
debug2: load_server_config: filename /etc/sshd_config
debug2: load_server_config: done config len = 206
debug2: parse_server_config: config /etc/sshd_config len 206
debug3: /etc/sshd_config:21 setting Protocol 2
debug3: /etc/sshd_config:46 setting RSAAuthentication yes
debug3: /etc/sshd_config:47 setting PubkeyAuthentication yes
debug3: /etc/sshd_config:113 setting Subsystem sftp     /bin/sftp-server
debug1: sshd version OpenSSH_5.6p1
debug3: Not a RSA1 key file /etc/ssh_host_rsa_key.
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug3: Not a RSA1 key file /etc/ssh_host_dsa_key.
debug1: read PEM private key done: type DSA
debug1: private host key: #1 type 2 DSA
debug1: rexec_argv[0]='/bin/sshd'
debug1: rexec_argv[1]='-D'
debug1: rexec_argv[2]='-ddd'
debug1: rexec_argv[3]='-e'
debug2: fd 3 setting O_NONBLOCK

 From: Andrew DeFaria-2 [via Cygwin] <>
To: anulav2 <> 
Sent: Tuesday, November 20, 2012 12:27 PM
Subject: Re: Passwordless authentication between two domains.

On 11/20/2012 9:46 AM, anulav2 wrote: 

> Hello, 
> I am unable to use passwordless authentication between two 2008 windows 
> servers in two different domains. 
> Account name is same in both domains. 
> I can authenticate using password but not otherwise. 
> I have setup RSA keys and authorized_keys file. Permissons on .ssh are 700 
> and .ssh/authorized_keys are 600. 
> I have tried uninstall and re-install twice. 
> and following is part of what i get when i increase verbosity. Is your home directory, oddly named /home/pal.rsync, set to 755? How 
about ~/.ssh? Also 755. No. 700. That may be the problem. My 
~/.ssh/authorized_keys is set to 644. My ~/.ssh/id_rsa is 600 but 
~/.ssh/ is 644. 

But I don't use any RSA anymore, I use DSA instead. I believe it is more 

Additionally is ~/.ssh/ the same on both machines? (Does diff 
return no differences?). I believe, since these are two different 
domains, that the generated keys will not be the same. If they are the 
same then regenerate them on both machines and compare them again. 

Also, ~/.ssh/ from Domain A should be added to the 
~/.ssh/authorized_keys on Domain B and visa versa from Domain B -> Domain A. 

Finally make sure that the key is contained in one long line. Often, 
depending on the user's editor and it's setting, when you paste into the 
editor the editor may insert new lines. 

These are the usual problems I see when people are attempting to set up 
passwordless authentication with ssh. 
Andrew DeFaria <> 
I went to a general store, but they wouldn't let me buy anything specific. 

Problem reports:
Unsubscribe info:

If you reply to this email, your message will be added to the discussion below: 
To unsubscribe from Passwordless authentication between two domains., click here.

View this message in context:
Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list