cygwin dlls address issue (cygconv-2.dll), unable to rebaseall

Mon Nov 26 21:16:00 GMT 2012

holy fuck... i was wondering about the address being like that myself,
but thats what it did by default, so whenever i tried rebasing i kept
it in the same address range
this is the current address after i used your starting location
/usr/bin/cygiconv-2.dll                  base 0x48bd0000 size 0x000fc000

when i did the rebase, i did get an error.. .but things started to work
$ ./rebaseall -b 0x5fe50000
      0 [main] xargs 8512 child_info_fork::abort: C:\cygwin.backup\bin\cygiconv-
2.dll: Loaded to different address: parent(0x410000) != child(0x5B0000)
xargs: cannot fork: Resource temporarily unavailable
/usr/bin/cygnetcdf_c++4-1.dll: skipped because nonexistent.
/usr/bin/cygnetcdff-5.dll: skipped because nonexistent.
/usr/bin/glut32.dll: skipped because not rebaseable
/usr/lib/perl5/5.14/i686-cygwin-threads-64int/CORE/cygperl5_14_2.dll: skipped be
cause nonexistent.

i'm not sure if its because i was in the middle of installing my
second instance of cygwin, but it somehow works now... serious voodoo
going on here.

So the interesting question is... why the hell did cygwin default to
that short address after i updated it?

On Mon, Nov 26, 2012 at 3:57 PM, Ryan Johnson
<> wrote:

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list