rm command missing after update

Larry Hall (Cygwin) reply-to-list-only-lh@cygwin.com
Thu Nov 15 03:01:00 GMT 2012

On 11/14/2012 9:40 PM, Nate Kennedy wrote:
> Greetings,
> I just re-ran the cygwin installer so that I could add svn.  After
> completing that installation, my rm command seems to have disappeared from
> my system.  I ran the cygwin installer again, to search the package library
> for rm so I could reinstall it, but I can't find it in the listings.  I've
> attached the ouput of $cygcheck -s -v -r, for background info.
> My $PATH is as follows:
> /usr/bin:/cygdrive/c/program files
> (x86)/git/bin:/cygdrive/c/windows/system32:/cygdrive/c/users/corey/tools:/usr/local/bin
> I've tried "which rm", to no avail.  I've also tried "ls -l $d/rm" and "find
> $d -name "rm"" in /bin, /usr/bin, and /usr/sbin, all to no avail.  I even
> tried looking in Windows Explorer.  rm just seems to have completely
> disappeared.
> Likewise, in the cygwin package library, I cannot find rm.  I am truly
> baffled by this one.

Looks like somehow 'rm' got removed.  That's certainly what your cygcheck
output says:

Missing file: /usr/bin/rm.exe from package coreutils
coreutils                  8.15-1               Incomplete

Reinstall the 'coreutils' package and you should be all set.



A: Yes.
 > Q: Are you sure?
 >> A: Because it reverses the logical flow of conversation.
 >>> Q: Why is top posting annoying in email?

Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple

More information about the Cygwin mailing list