Info for the item "does patch.exe work different than other unx patch tools?" (i.e. "hunk 1 out of 3 hunks failed")

Ryan Johnson
Thu Nov 8 13:18:00 GMT 2012

On 08/11/2012 5:30 AM, Thomas Höhenleitner wrote:
> Hello,
> using Cygwin patch.exe in a batch file I ran into the problem that
> patch failed for some reason ("hunk 1 out of 3 hunks failed"):
> Investigating this issue I found that inserting "unix2dos my.patch"
> before applying the patch was my friend!
> Being paranoid I tried  "dos2unix my.patch" before applying the patch
> - and it was my friend too!
I've hit problems trying to apply a dos-like patch to a unix-like file, 
and vice-versa, but not what you describe. Also, problems with line 
endings tend to go all-or-nothing: either all hunks fail (all line 
endings differ), or all succeed in the absence of other conflicts.

I almost wonder if the file you edited somehow got inconsistent line 
endings only for the changed lines; that would imply that the two 
successful hunks have only insertions and/or deletions, while the failed 
hunk has actual changes.

Hard to say without seeing the files involved, tho. Also, did you try 
-b/-w with diff, and/or -l with patch?


Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list