Problem with HTTPS in LWP module in Perl

Björn Kautler
Tue Nov 6 22:52:00 GMT 2012

2012/11/6 Achim Gratz <>:
> Björn Kautler writes:
>> I'm having a problem with https requests to
>> "" in perl.
> This has nothing to do with Cygwin, the same error happens on Linux:
> $ perl -e 'use LWP::Simple;' -e '($r=get("")) or print "$!\n$@\n";print "$r\n";'
> Connection reset by peer
> Can't connect to
> LWP::Protocol::https::Socket: SSL connect attempt failed with unknown error error:00000000:lib(0):func(0):reason(0) at /usr/lib/perl5/vendor_perl/5.16.0/LWP/Protocol/ line 51.
> The error message is slightly different than on Cygwin.  I haven't
> looked further into this, but I wouldn't be surprised if the server
> simply doesn't accept connections from LWP and some other user agents
> that are typically used for crawling…

For me the command you wrote works absolutely fine on Ubuntu Karmic
and Debian Lenny, but shows the same timeout behaviour on Cygwin.
I get the exact same error message on Cygwin like you wrote, just with
perl 5.14 in the path.
As this is hanging after the "Client Hello" and while waiting for the
"Server Hello" I don't think that a blocking of some user agent is
possible at this stage, because this is before the initial SSL
handshake took place and thus a user agent is not available.
Also on Ubuntu and Debian it is working fine here.

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list