sshd crashing

Pawel Jasinski pawel.jasinski@gmail.com
Mon Jul 30 22:50:00 GMT 2012


hi,

I have already tried. So my first step is to recompile sshd without
any changes (adding debug etc.)
As far as I can tell from documentation, sshd is type 3, covered by
cygport tool.
So I did:

$ cygport /usr/src/openssh-6.0p1-2.cygport prep
>>> Preparing openssh-6.0p1-2
*** Info: gnupg must be installed in order to check signatures.
>>> Unpacking source openssh-6.0p1.tar.gz
>>> Preparing working source directory
*** Info: applying patch openssh-6.0p1-2.cygwin.patch:
patching file CYGWIN-PATCHES/setup.hint
*** Info: applying patch openssh-6.0p1-2.src.patch:

things are ok until now. If I should do anything else, please tell me.

now step 2:

$ cygport /usr/src/openssh-6.0p1-2.cygport compile
>>> Compiling openssh-6.0p1-2
/usr/src/openssh-6.0p1-2/src/openssh-6.0p1/configure
--srcdir=/usr/src/openssh-6.0p1-2/src/openssh-6.0p1 --prefix=/usr
--exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin
--libexecdir=/usr/lib --datadir=/usr/share --localstatedir=/var
--sysconfdir=/etc --datarootdir=/usr/share
--docdir=/usr/share/doc/openssh -C --libexecdir=/usr/sbin
--with-kerberos5=/usr --with-tcp-wrappers --with-libedit
--with-xauth=/usr/bin/xauth
configure: loading cache config.cache
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/usr/src/openssh-6.0p1-2/build':
configure: error: C compiler cannot create executables
See `config.log' for more details
*** ERROR: configure failed

If I look at config,log the things look funny around gcc invocation,
but I am kind of novice to cygport and can not figure out what's going
on:

gcc -ggdb -O2 -pipe
-fdebug-prefix-map=/usr/src/openssh-6.0p1-2/build=/usr/src/debug/openssh-6.0p1-2
-fdebug-prefix-ma
p=/usr/src/openssh-6.0p1-2/src/openssh-6.0p1=/usr/src/debug/openssh-6.0p1-2
  conftest.c  >&5
cc1: error: unrecognized command line option
"-fdebug-prefix-map=/usr/src/openssh-6.0p1-2/build=/usr/src/debug/openssh-6.0p1-2"
cc1: error: unrecognized command line option
"-fdebug-prefix-map=/usr/src/openssh-6.0p1-2/src/openssh-6.0p1=/usr/src/debug/openssh-6.0

What am I missing?

Cheers,
Pawel

On Mon, Jul 30, 2012 at 4:13 PM, Larry Hall (Cygwin) <your spam filter
complains about it> wrote:
> On 7/28/2012 5:27 AM, Pawel Jasinski wrote:
>
> <snip>
>
>
>> I also tried to core dump with:
>> /usr/bin/cygrunsrv -I sshd -d "CYGWIN sshd" -p /usr/sbin/sshd -a "-D"
>> -y tcpip -u cyg_server -w xxxxxx  -e CYGWIN="error_start=dumper -d %1
>> %2"
>>
>> The file is there (/sshd.exe.core), but again gdb doesn't show any
>> encouraging information:
>>
>>
>> $ gdb /usr/sbin/sshd.exe sshd.exe.core
>> GNU gdb (GDB) 7.3.50.20111026-cvs (cygwin-special)
>> Copyright (C) 2011 Free Software Foundation, Inc.
>> License GPLv3+: GNU GPL version 3 or later
>> <http://gnu.org/licenses/gpl.html>
>> This is free software: you are free to change and redistribute it.
>> There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
>> and "show warranty" for details.
>> This GDB was configured as "i686-cygwin".
>> For bug reporting instructions, please see:
>> <http://www.gnu.org/software/gdb/bugs/>...
>> Reading symbols from /usr/sbin/sshd.exe...(no debugging symbols
>> found)...done.
>
>                                              ^^^^^^^^^^^^^^^^^^^^^^^^^^
> Without debug symbols, you're not going to see much useful in the debugger.
> I'd recommend rebuilding the package as debug and trying again.
>
> --
> Larry
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list