sshd crashing

Pawel Jasinski pawel.jasinski@gmail.com
Fri Jul 27 23:05:00 GMT 2012


as I said I did rebaseall :-(
In a mean time I also tried with CYGWIN=pipe_byte, no change
At the moment of crash there is nothing new in the /var/log/sshd.log

--pawel


On Sat, Jul 28, 2012 at 12:52 AM, Reini Urban <rurban@x-ray.at> wrote:
> On Fri, Jul 27, 2012 at 4:44 PM, Pawel Jasinski wrote:
>> I have a fresh installation of cygwin on xp and win7 (both run 1.17.16-1).
>> I have run ssh-host-config followed by rebaseall. The CYGWIN variable
>> for sshd is not set.
>> I have tried with and without priv. separation.
>> It is started with cygrunsrv -S sshd
>> I can connect with ssh localhost. Things are ok until I do vi
>> /etc/profile. At this moment it crashes.
>>
>> Now if I try the version without priv separation to start by hand:
>> /usr/sbin/sshd -D -d -e things go well and it does not crashes when in
>> ssh session /etc/profile is edited.
>> Am I missing something in config?
>
> Inspect /var/log/sshd.log for obvious rebase errors and run rebaseall then.
> I fixed the same problem this way.
>
>> sshd: PID 484: service `sshd' failed: signal 11 raised
> --
> Reini Urban
> http://cpanel.net/   http://www.perl-compiler.org/
>
> --
> Problem reports:       http://cygwin.com/problems.html
> FAQ:                   http://cygwin.com/faq/
> Documentation:         http://cygwin.com/docs.html
> Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple
>

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list