sshd crashing

Pawel Jasinski pawel.jasinski@gmail.com
Fri Jul 27 21:45:00 GMT 2012


hi,

I have a fresh installation of cygwin on xp and win7 (both run 1.17.16-1).
I have run ssh-host-config followed by rebaseall. The CYGWIN variable
for sshd is not set.
I have tried with and without priv. separation.
It is started with cygrunsrv -S sshd
I can connect with ssh localhost. Things are ok until I do vi
/etc/profile. At this moment it crashes.

Now if I try the version without priv separation to start by hand:
/usr/sbin/sshd -D -d -e things go well and it does not crashes when in
ssh session /etc/profile is edited.
Am I missing something in config?

--pawel

Info from Event Viewer:

The description for Event ID 0 from source sshd cannot be found.
Either the component that raises this event is not installed on your
local computer or the installation is corrupted. You can install or
repair the component on the local computer.

If the event originated on another computer, the display information
had to be saved with the event.

The following information was included with the event:

sshd: PID 484: service `sshd' failed: signal 11 raised
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cygcheck
Type: application/octet-stream
Size: 56920 bytes
Desc: not available
URL: <http://cygwin.com/pipermail/cygwin/attachments/20120727/b82e0c1a/attachment.obj>
-------------- next part --------------
--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple


More information about the Cygwin mailing list