Maxima can't write to /dev/stdout

Earnie Boyd earnie@users.sourceforge.net
Thu Jul 26 13:21:00 GMT 2012


On Thu, Jul 26, 2012 at 5:46 AM, Corinna Vinschen wrote:
> On Jul 26 09:23, Achim Gratz wrote:
>> Corinna Vinschen <corinna-cygwin <at> cygwin.com> writes:
>> > And here something goes wrong.  If I call `echo foo > /dev/stdout' in
>> > bash, the above normalize_posix_path calls already handle the path
>> > /proc/196/fd/1, not just /proc/196/fd as lisp does.
>>
>> Thanks for having a look, that got me one step further.  Maxima uses a (captive)
>> clisp and the standalone clisp makes the same error:
>>
>> [1]> (open "/dev/stdout")
>>
>> *** - OPEN: File #P"/proc/3348/fd/" does not exist
>>
>> So the same thing happens in clisp and it seems to affect only(?) symlinks
>> pointing to /proc, some other symlinks I tried that were pointing to /dev/tty as
>> a test have not had that problem.  Is it possible that clisp uses an API that
>> isn't aware of /proc somehow?
>
> That *should* be impossible.  The path handling is supposed to be
> transparently handling all real and virtual paths, regardless of
> the function calling the path handling stuff.
>
> If you can nail that down to the actual calls and decisions clisp is
> doing, it might help to find the cause.

Maybe something to do with the 1 looking like an integer instead of a
valid path or directory?  Don't know but thought I would give my
initial thoughts.

-- 
Earnie
-- https://sites.google.com/site/earnieboyd

--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list