Maxima can't write to /dev/stdout

Corinna Vinschen
Thu Jul 26 09:47:00 GMT 2012

On Jul 26 09:23, Achim Gratz wrote:
> Corinna Vinschen <corinna-cygwin <at>> writes:
> > And here something goes wrong.  If I call `echo foo > /dev/stdout' in
> > bash, the above normalize_posix_path calls already handle the path
> > /proc/196/fd/1, not just /proc/196/fd as lisp does.
> Thanks for having a look, that got me one step further.  Maxima uses a (captive)
> clisp and the standalone clisp makes the same error:
> [1]> (open "/dev/stdout")
> *** - OPEN: File #P"/proc/3348/fd/" does not exist
> So the same thing happens in clisp and it seems to affect only(?) symlinks
> pointing to /proc, some other symlinks I tried that were pointing to /dev/tty as
> a test have not had that problem.  Is it possible that clisp uses an API that
> isn't aware of /proc somehow?

That *should* be impossible.  The path handling is supposed to be
transparently handling all real and virtual paths, regardless of
the function calling the path handling stuff.

If you can nail that down to the actual calls and decisions clisp is
doing, it might help to find the cause.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list