Can't resolve "Your group is currently "mkpasswd"'
Thu Jul 19 02:35:00 GMT 2012

I just tried to set up cygwin on my new corporate pc (I have admin
privileges on the machine but not on the overall corporate network).

I keep getting the infamous 'Your group is currently "mkpasswd"' every
time I open a new terminal.

Since this is a domain, I first tried "mpasswd -l -d >| /etc/passwd"
but the domain lookup seemed to hang forever (after first generating
the local group portion). Note that "mkgroup -l -d >| /etc/group
worked but was slow.

I then tried "mkpasswd -l -c >| /etc/passwd" followed by "mkgroup -l
-c >| /etc/group"

But I still got the same 'mkpasswd' error message and indeed running
groups just returned 'mkpasswd' and running 'id -a' returned:
	   uid=400(MYUSERNAME) gid=401(mkpasswd) groups=401(mkpasswd)

I have never had this problem before on non-domain PC's.

Any thoughts on what I need to do to fix this?

Problem reports:
Unsubscribe info:

More information about the Cygwin mailing list