Open URLs with # using cygstart.exe

Ryan Johnson ryan.johnson@cs.utoronto.ca
Fri Jul 13 13:19:00 GMT 2012


On 13/07/2012 9:02 AM, Alexander Konovalov wrote:
> Thanks for replies. I am running 64-bit Windows 7, Cygwin 1.7.11 (2012-02-24).
> The default browser is Chrome, but I've tried with Firefox and InternetExplorer -
> same result whenever I'm using single quotes or not with each of the three
> browsers. Remote URLs indeed work fine. With the local URL address line of the
> browser contains truncated URL without '#...' part so maybe cygstart parses
> its argument differently dependently whether it starts with file:// or http://?
Just say no to http://cygwin.com/acronyms/#TOFU

Also, you've got a fairly old version of cygwin there...

Cygstart does not actually parse general URIs. For a long time it had a 
special case that tested explicitly for `http:', and recently added 
`mailto:' after a similar issue arose [1]. Ironically, most URIs seem to 
work precisely because cygstart *doesn't* know what to do with them and 
passes them along as-is, giving Windows a chance to do the right thing.

[1] http://cygwin.com/ml/cygwin/2012-03/msg00810.html
Ryan



--
Problem reports:       http://cygwin.com/problems.html
FAQ:                   http://cygwin.com/faq/
Documentation:         http://cygwin.com/docs.html
Unsubscribe info:      http://cygwin.com/ml/#unsubscribe-simple



More information about the Cygwin mailing list